
Iktrix Impulse 3
Manual

Warning
• Motion control is dangerous when done incorrectly.

• Anyone using Iktrix Impulse must read this manual first.

• Anyone installing Iktrix Impulse must make sure all users read this manual.

• This software might contain bugs. You should backup data and run new moves slowly.

• Iktrix will not be held liable for any losses incurred.
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Chapter 1

Introduction
This manual is task based. The chapters are arranged in approximately the same order as

you will need to do the tasks.

Menus  levels  are  referred  to  using  arrows.  Window  → Settings/Preferences  →

Preferences... corresponds to the ‘Preferences...’ menu item in the ‘Settings/Preferences’ sub

menu in the ‘Window’ menu in Maya’s title bar.

Menus

Options in other menu bars, e.g. a panel will be indicated appropriately. Some tasks can

be achieved in more than one way. This is indicated by an `Option X:` heading. Read on to

find an alternative way of doing things. Once you have finished an ‘Option’ you can pass over

the other options to the next (non option) task.

Although  this  manual  covers  some  of  Maya’s  basic  functions  it  is  no  substitute  for

learning Maya through the usual channels, i.e. manual, tutorials and training. That said, you

don’t need to be a Maya guru to create quite complicated rig moves.

A basic understanding of motion control is required to use this software.

You should learn how to use this software before going on set!
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Chapter 2

Installation
• Download the installer.

• You can install Iktrix Impulse v3 without uninstalling Iktrix Impulse v2, but since version

3 supersedes version 2 in every way it is recommended that version 2 is uninstalled first.

• Backup any previous licenses and uninstall any old version of Iktrix Impulse 3.

• Double click on the setup file and follow the on-screen instructions.

• You must restart the computer before you can use the plug-in.

• Install the dongle driver. This is needed even if you are not using a dongle. Iktrix uses the

DESKey DK3 USB dongle. The driver can be downloaded from:

http://www.deskey.co.uk/deskey_downloads.php
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Chapter 3

Start
3.1 Start Maya

Start Maya and perform the following tasks once for each user:

3.2 Units
Maya should be set to work in units of meters and degrees for use with Iktrix Impulse.

Check this after loading files incase they have been saved in other units. Scenes can be scaled

by parenting everything to an empty group node.

3.3 Load Plug-In
• Select Window → Settings/Preferences → Plug-in Manager...

• Make sure the loaded check-box next to the Iktrix Impulse mll matching your running

version of Maya is ticked. If you don't have a valid license the plug-in will not load. Please

read the next section on how to license Iktrix Impulse.

• Optionally tick the ‘auto’ check-box to avoid having to automatically load Iktrix Impulse

every time the user starts Maya.

• This must be repeated for each user.
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3.4 License Iktrix Impulse
If you run Iktrix Impulse without a license it will  display an error message along with any

system IDs for you to email to Iktrix (support@iktrix.com). These are needed to get a license for

the computer or dongle. The system IDs, license status (e.g. time remaining) and license errors are

displayed in Maya's command history. This can be seen by opening the script editor.

Maya command history in the script editor.

Iktrix Impulse also checks that the system date and time has not been turned back. This check

can  sometimes  produce  false  positives.  If  you  think  this  is  the  case  then  please  email

support@iktrix.com.

Non dongle, system IDs are MAC addresses and unique to each network interface card (not

modems). If there are no system IDs listed you need to get a network card or a dongle. If there is

more than one system ID it  is because you have more than one network card.  If any of these

network cards are used sporadically their ID should not be used. Send a system ID that corresponds

to a network card permanently connected to the computer. Windows XP users should also make

sure they are not sending the physical address of any network bridges. If in doubt consult your

system administrator. Licenses are non transferable for the period of the license. If you have bought
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a full license request short licenses with (free) renewals if you think you will need to change the

computer or are likely to loose the dongle!

To get a full list of MAC addresses (system IDs) and their description enter:

ipconfig /all
At the windows command prompt. If in doubt send this information with every license request.

Output of ipconfig /all showing the system ID/physical address/MAC address

3.5 Create a Rig
• This can (optionally) be done later after creating a camera path.

• Select IktrixImpulse → Rig → Milo.

• Select the setups directory for the rig. This is the directory containing Mark Robert's Flair (v3+)

AXIS.DBF and KINE.CYC files. Every rig is different and has a unique group of setup files.

Creating moves with a different rig’s setup file will produce incorrect moves, and may lead to

the rig being damaged. If you just want to ’play’ with the software or plan to setup the rig later

you  can  use  the  default  setup  files  from  C:\Program  Files\Iktrix\Impulse\3.0\Default

Setups\<rig>

• Click in a 3D view panel and hit key ‘a’ to frame the rig to the panel’s view size.
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• If you want a good representation of the rig turn on smooth shading by selecting Shading →

Smooth Shade All from the panel’s menus.

3.6 Setup The Rig
If you have the information you should setup the nodal point offset and your virtual camera(s).

The nodal point offset is the position and rotation of the viewing frustum relative to the rig’s pan-

tilt-roll intersection (or camera mount point). The nodal point is changed by selecting its node (it is

just  before the rig camera in  the hierarchy) and altering the translateX (and perhaps the other

translate and rotate) in the channel box.

To quickly select a node in the hierarchy first open the Outliner. The Outliner can be started

from 'Window...' menu or from the toolbox by clicking on the 'Persp/Outliner' layout button.
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Persp/Outliner layout button.

To expand an entire hierarchy hold down the left Shift key and click on the root node whose

hierarchy you wish to expand. Find the required node by scrolling down.

Left shift click on a node to expand it's hierarchy.
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Be careful - Maya’s cameras don’t have nodal point offsets - in fact they are nodal points. They

do provide editable attributes to match most of the other properties found in film cameras. This

includes (but is not limited to):

• Shutter angle.

• F Stop.

• Focal Length.

• Vertical Film Aperture.

• Horizontal Film Aperture.

• Lens Squeeze Ratio.

• Angle (Field) of View.

• Film Gate.
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• Camera Aperture.

• Film offset.

These can be set to match the real film camera by selecting the camera and opening its attribute

editor.
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Chapter 4

Create a Camera Move
4.1 Option 1: Key-frame The Rig’s Goal
• Open the outliner (Window → Outliner...) and select the rig’s goal, e.g.  MiloGoal if not

already selected. The goal is a locator with a child camera.

The Outliner

• Choose a frame number for when you want the pre roll to start (optional - you can let the

motion control system add this in, if it is able to do so). Change frame by clicking on the

‘Time Slider’ or typing a number in the ‘Current Time’ text box.

Time Slider

• Use Maya’s ‘Move’ and ‘Rotate’ tools to translate and rotate the rig’s goal. The rig will

Page 13 of 30



Iktrix Impulse Create a Camera Move

(always)  try  to  match  the  goal’s  translation  and  rotation.  Once  you  are  satisfied  with  the

translation and rotation hit  the ‘s’ key to  key-frame the goal’s translation and rotation at the

current time.

Move and Rotate Tools

• Repeat these steps at different frame numbers for the start of the move, end of the move and end

of the pre roll (optional).

• By default Maya creates key frames with spline tangents. This means that the initial speed of the

rig will be non zero. If you are doing your own pre and post roll you don’t want this to be the

case.  With  the goal  still  selected choose IktrixImpulse → Tools → Zero Ends Speeds (this

works on any selected object’s keyframed animation).

• You can see  the  key frames  and interpolated  translation  and rotation  of  the  goal  using the
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Animation Graph Editor.  With  the goal selected choose  Windows → Animation Editors →

Graph Editor... then hit the ‘f’ to fit the curves to the panel.

Graph Editor

4.2 Option 2: Key-frame a Camera
• This is an example of an approach where the rig can optionally be loaded after the camera move

has been created.

• Choose and create any type of camera from Create → Cameras or use IktrixImpulse →  Tools

→ Camera, Aim and Roll. By default Maya creates cameras scaled for working in centimeters,

i.e their iconic representation in the scene is very small. This can be corrected by making sure

the camera is selected and choosing IktrixImpulse → Tools → Scale Camera.

• Choose a start  time for your pre-roll (optional) by clicking on the ‘Time  Slider’ or typing a

frame number in the ‘Current Time’ text box.

• Use Maya’s ‘Move’ tool to translate the camera, aim (optional), and up points (optional). If you

are using the camera produced by IktrixImpulse →  Tools → Camera, Aim and Roll you must

animate translation using the camera group instead.  You can also use Maya’s ‘Rotate’ tool to
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rotate an unconstrained camera (one without aim and up points or with aim and roll). Once you

are happy with the camera position and rotation hit the ‘s’ key to add an animation key-frame on

the currently selected object. Bear in mind you may need to do this three times for each keyed

frame (camera object, aim object, and up object).

• Repeat these steps at different frame numbers for the start of the move, end of the move and end

of the pre roll (optional).

• By default Maya creates key frames with spline tangents. This means that the initial speed of the

camera and thus the rig will be non zero. You can either let the motion control system and a pre

and post roll (if possible) or zero the start and end speed yourself. To do this select the camera

and then choose IktrixImpulse → Tools → Zero End Speeds.

• Select  the  camera  and  the  goal  and  select  IktrixImpulse  → Tools  → Constrain  Goal  To

Transform Node.

4.3 Option 3: Create a Motion Path
With this option you create one or more curves and then attach either a camera (with optional

aim and up) to the curve or just the goal.

You will find it easiest to draw a curve using one of the orthographic views,  usually the top

view. This can be displayed by clicking on the ‘four view’ button and clicking on the panels menu

bar.You can expand the currently selected view to the whole window by hitting the ‘space’ key.
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Orthographic Views

• Choose Create → EP Curve Tool (actually you can use any type of curve e.g. a nurbs circle or

even a square - obvioulsy you’ll have to slow down at the corners!). You may want to click on

the ‘Tool Options’ box to the right of the menu item to choose the type of curve to draw, we

recommend you use cubics. The EP Curve Tool (as opposed to the CV Curve Tool) means the

curve will pass through the points.
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EP Curve Tool Options

• For less ‘organic’ shaped curves you can switch on ‘Snap to grids’ in the status line.

Page 18 of 30



Iktrix Impulse Create a Camera Move

Snap To Grids

• Create the curve by clicking out points and hit the ‘Return’ key to finish.

• You may want to translate the curve out of the plane you created it in. If you created it in the top

view it will be in the plane of the floor. Obviously this doesn’t represent a very good camera

move! You can translate the curve using Maya’s move tool or more accurately by typing a value

into the translate channel.

The Channel Bar

• Once you have created your curve(s)  attach your object(s) (goal/camera,  aim and up) to the

curves. This is done by first selecting the object then the curve and then choosing Animate →

Motion Paths → Attach To Motion  Path. Make sure that the ‘follow’ option is switched off

using the Tool Options icon to the right of the ‘Attach To Motion Path’ menu item. With the

option on Maya will make the camera look along the path which is generally not wanted.
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Turning off Follow

• By default this will animate the object along the path between the current start and finish times.

The aformentioned tool options window will let you choose a different range.
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Chapter 5

Check The Move
Iktrix impulse will not exceed axis value limits but any solution will have a limit to how

fast it can be run. To find out how fast you can run a move select all the rig’s axes and select

IktrixImpulse → Tools → Max Playback Rate. A quick way to select an entire rig’s axes is to

select the rig’s root group node in the outliner and then choose Edit → Select Hierarchy.

A progress bar will appear whilst Iktrix Impulse checks the move and dialog will appear

specifying the approximate max playback frame rate. Iktrix Impulse takes the current Maya

frame rate  into  account  when  calculating  this  figure.  Please  be  aware  that  this  figure  is

approximate, the real move may be able to run a little bit faster or slower depending on the

condition of the real rig and how well it is setup. It is worth leaving a 5% room for change in

the speed.

It may be possible to increase the maximum playback by adjusting the solution. See the

chapter ‘Adjusting The Solution’ on how to do this.

Page 21 of 30



Chapter 6

Adjusting The Solution
Unfortunately Iktrix Impulse can not read your mind! It must make assumptions about

what type of result you want and solve the inverse kinematics problem accordingly.

It is possible to change the way Iktrix Impulse behaves to get solutions that better meet

your requirements, e.g. less flex, faster camera motion, avoid pieces of set, etc.

Iktrix Impulse allows you to specify preferred axis values for extend and angle. It is also

possible to override the extend and angle axes so that each axis does exactly what you tell it

to. With override Iktrix Impulse uses the rest of the axes to compensate and solve the inverse

kinematics problem.

It is possible to change the axes value, speed and acceleration limits although we do not

recommend you do this unless you really know what you are doing. If you get this wrong you

could damage the rig, set or other people.

6.1 Keep Head Level
By default Iktrix Impulse keeps the outer arm of Milo rigs vertical. This reduces camera

shake but does restrict the rig's range of movement. To turn it off select the Milo root node

and open the attribute editor (Ctrl+A or Window → Attribute Editor). Find the 'Keep Head

Level' check box and (de)select as required.
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Keep head level attribute.

6.2 Preferred Axes Values
Think of preferred axis value as a suggestion to Iktrix Impulse that it will bear in mind when

solving the inverse kinematics problem. It is not a ’command’ and it may occasionally appear that

Iktrix Impulse has completely ignored it, e.g. you would prefer the outer arm of a Milo to be down

but Iktrix Impulse lifts it up when stretching for a very high move. There was no other way to

achieve the result so Iktrix Impulse lifted the outer arm up – although it may well do this as late as

possible if the rest of the move is nearer the floor. The preferred value can be changed in the extend

and angle axes' attribute editor. Note: This is the axis transform node not the axis shape node.

If you always want  the arm down you are better  off using override (see the later section).

Preferred axis values can be constant for the whole move or key-framed so they change over the

playback range, e.g. at the start I would prefer the arm up and at the end I would prefer the arm

down.

You can use the angle and extend preferred axis values to avoid tilt 90 problems where the pan

axis has to flip because the pan and roll axes have lined up.
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Axis Preferred Value Attribute

6.3 Override Values
Angle and extend override values are entered in much the same way as preferred values and can

similarly be key-framed. Once you have entered an override value you must switch it on using the

enable override check-box. Iktrix Impulse will always obey an enabled override value and will use

any other non overridden axes to try and solve the problem.

6.4 Dsiable Axes
You can disable unwanted axes. If angle and/or extend are dsiabled the rest of the axes can

compensate. Disabling other joints will severly limit the rig's ability to solve the problem. If you are

doing a vertical move through camera at rig zero you may want to disable the pan axis to stop it

from flipping as it goes through tilt 90. Of course you wont be able to pan the camera is you do this.

This unfortunately a limitation of the rig.
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Chapter 7

Export The Move
You  should  use  Maya  scene  files  to  transfer  pre-visualised  motion  control  to  other

computers that are running Iktrix Impulse 3. Only export the move when you want to run it on

a real rig.

You must only run moves on the rig for which they were solved in Iktrix Impulse (which

requires the virtual rig to have been set up using that rig’s setup files). If you don’t bad things

will happen.

Iktrix Impulse will export all selected axes values for every frame in the current Playback

range. To do this select all the axes and then IktrixImpulse → Export → Flair. A quick way to

select an entire rig’s axes is to select the rig’s root group node in the outliner and then choose

Edit →  Select  Hierarchy.  The  move  is  exported  as  a  flair  raw  axis  move  in  units  of

centimeters.

You can use IktrixImpulse → Export → Move Kinematics to export a file for viewing in

a spreadsheet like Microsoft Excel. You can use this to plot graphs of the axis positions,

speeds and accelerations.
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Running The Move
Motion control rigs are potentially very dangerous pieces of equipment. At the very least

they can be expensive to  fix!  Rigs  should  only be operated by qualified personnel.  This

manual is not a manual on how to operate a rig.

Import the move into Flair using CGI import. You can either import the move as mimic or

a list of frames (non mimic). That advantage of mimic is that it does not adversely tax Flair,

the disadvantage is that flair does not perform speed and acceleration limit checking when pre

calculating the move. For long moves you will have to use mimic. For shorter moves (<1000

frames) turn it off. You must zero all the axis fairings and set them to prevent curve reversal

to stop flair changing the motion paths. Otherwise you may get a jolt at the beginning and end

of the move and limit errors. Make sure that you run any new moves very slowly the first

time, watch the rig and check for collisions.
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Import A Move
You can import a cartesian camera (path) move exported from Flair. The move must have

been exported in metres using the Maya Y up coordinate system. This function will produce a

Maya camera with animated position, aim and roll. To import the move select IktrixImpulse

→ Import → Flair Carts...
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Chapter 10

Non Standard Milo Configurations
10.1 Slimline Head

By default the Milo model shows a Guiness head, but it is possible to show a slimline

head instead. The following procedure changes the graphics only. It is still up to the user to

make sure the correct nodal point offset is entered as explained earlier. The rest of the head

setup is in the setup files used to configure the rig.

From the window menu select the 'Outliner..' menu item.

In the outliner click on the 'Milo' node.

Open the attribute editor using the 'Window' menu.
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In the attribute editor scroll down to the bottom and expand the extra attributes section. Click

on slimline head.

The Guiness head should turn into a slimline head.
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10.2 Wotan Support
A Wotan is a long arm Milo with a locked off extend axis.

Just load the correct Milo setups, the graphics will adjust accordingly - depending on the length

of the arm in the setup file. There are three arms lengths represented by the graphics, 3.6 meters, 6

meters or 8.5 meters. Disable the extend axis in the attribute editor.
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